package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)color=(?:red|green|blue)`)
var str = `color=blue
color=white
color=red
color=?:red
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}