$re = '/color=(?:red|green|blue)/m';
$str = 'color=blue
color=white
color=red
color=?:red
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);