#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?![\d.]+)((?!-))(xn--)?[a-z0-9][a-z0-9-_]{0,61}[a-z0-9]{0,1}\.(xn--)?([a-z0-9\._-]{1,61}|[a-z0-9-]{1,30})"
Local $sString = "www.example.com" & @CRLF & _
"subdomain.example.com" & @CRLF & _
"subdomain.example.co.uk" & @CRLF & _
"" & @CRLF & _
"192.168.0.0" & @CRLF & _
"127.0.0.1" & @CRLF & _
"" & @CRLF & _
"Lucia told me about www.example.com. However, whenever I visit the site the IP 127.0.0.1 shows up."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")