$re = '/(?![\d.]+)((?!-))(xn--)?[a-z0-9][a-z0-9-_]{0,61}[a-z0-9]{0,1}\.(xn--)?([a-z0-9\._-]{1,61}|[a-z0-9-]{1,30})/m';
$str = 'www.example.com
subdomain.example.com
subdomain.example.co.uk
192.168.0.0
127.0.0.1
Lucia told me about www.example.com. However, whenever I visit the site the IP 127.0.0.1 shows up.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);