// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)# regex with example test case: <https://regex101.com/r/Xf0Xah/4>
# IP, ex: 1.2.3.4
(?P<IP>
\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}
)
# ignore the smallest possible match between them
(:.*?)
# Time in Milliseconds. match requires suffix, but drop only return the integer
(?:
(?P<Time>
\d+
)
ms
)
").unwrap();
let string = "
Pinging google.com [142.250.191.142] with 32 bytes of data:
Reply from 142.250.191.142: bytes=32 time=24ms TTL=113
Reply from 142.250.191.142: bytes=32 time=20ms TTL=113
Reply from 142.250.191.142: bytes=32 time=19ms TTL=113
Reply from 142.250.191.142: bytes=32 time=21ms TTL=113
Ping statistics for 142.250.191.142:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 19ms, Maximum = 24ms, Average = 21ms";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}