import Foundation
let pattern = ##"""
# regex with example test case: <https://regex101.com/r/Xf0Xah/4>
# IP, ex: 1.2.3.4
(?P<IP>
\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}
)
# ignore the smallest possible match between them
(:.*?)
# Time in Milliseconds. match requires suffix, but drop only return the integer
(?:
(?P<Time>
\d+
)
ms
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
Pinging google.com [142.250.191.142] with 32 bytes of data:
Reply from 142.250.191.142: bytes=32 time=24ms TTL=113
Reply from 142.250.191.142: bytes=32 time=20ms TTL=113
Reply from 142.250.191.142: bytes=32 time=19ms TTL=113
Reply from 142.250.191.142: bytes=32 time=21ms TTL=113
Ping statistics for 142.250.191.142:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 19ms, Maximum = 24ms, Average = 21ms
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)