package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+)\s+(\d{2}\s?\d{3}|\d{5})\s+((?:\S+\s)*\S+)\s*(.*?)$`)
var str = `15 rue des Tilleuls - 54 550 PONT ST VINCENT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}