$re = '/^(.+)\s+(\d{2}\s?\d{3}|\d{5})\s+((?:\S+\s)*\S+)\s*(.*?)$/m';
$str = '15 rue des Tilleuls - 54 550 PONT ST VINCENT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);