$re = '/\b(\w{4,})\b(?=.*?(\1).*?(\1))/m';
$str = 'How to select more and more of words and words words and even more of those more';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);