re = /\b(\w{4,})\b(?=.*?(\1).*?(\1))/m
str = 'How to select more and more of words and words words and even more of those more'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end