package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)\h+(\w+)(.*)`)
var str = `one two three four`
var substitution = "\2, \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}