const regex = /(?:\b(tlf|mobil|telephone|mobile|tel)\b)?[^\w\n]*((?:\(\+45\)|\+45)?\s*\d{2}\s?\d{2}\s?\d{2}\s?\d{2})(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b(tlf|mobil|telephone|mobile|tel)\\b)?[^\\w\\n]*((?:\\(\\+45\\)|\\+45)?\\s*\\d{2}\\s?\\d{2}\\s?\\d{2}\\s?\\d{2})(?!\\d)', 'gm')
const str = `tel.: +45 09827374, +45 89895867, some kind of text...
mobil: +45 20802020, +45 20802001,
tlf.: +45 5555 1212
tlf: +4567890202Girrafe`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}