$re = '/(?:\b(tlf|mobil|telephone|mobile|tel)\b)?[^\w\n]*((?:\(\+45\)|\+45)?\s*\d{2}\s?\d{2}\s?\d{2}\s?\d{2})(?!\d)/m';
$str = 'tel.: +45 09827374, +45 89895867, some kind of text...
mobil: +45 20802020, +45 20802001,
tlf.: +45 5555 1212
tlf: +4567890202Girrafe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);