$re = '/(?i:ab)II/m';
$str = 'abii
abII
Abii
AbII
ABii
ABII';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);