$re = '/^(.*?)OldKeyword/m';
$str = 'OldKeyword stuff stuff stuff
stuff stuff stuff OldKeyword stuff stuff stuff';
$subst = "hashtag Comments\n$1NewKeyword";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;