import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0[1-9]|1[0-9]|2[0-9]|3[01])\\.(0[1-9]|1[012])\\.([0-9]{4}) ([0-1][0-9]|2[0-3]):([0-5][0-9])";
final String string = "11.11.1111 24:51";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}