re = /(0[1-9]|1[0-9]|2[0-9]|3[01])\.(0[1-9]|1[012])\.([0-9]{4}) ([0-1][0-9]|2[0-3]):([0-5][0-9])/m
str = '11.11.1111 24:51'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end