re = /(?:\G(?!\A)|{)
[^{}]*?\K
ostrich/x
str = 'cat {mouse ostrich dog ostrich} fish {ostrich} ostrich'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end