using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^_.*(*SKIP)(*F)|\[\[|]]";
string input = @"## [[zoom]] _[v]_
>[[move]] | [[very]] | [[quickly]]
__Synonyms__: [[buzz]] | [[dart]] | [[dash]] | [[dive]] | [[flash]] | [[fly]] | [[hum]] | [[hurtle]] | outstrip | [[rip]] | [[rocket]] | [[rush]] | [[shoot]] | [[shoot]] up | [[skyrocket]] | [[speed]] | [[streak]] | [[surge]] | [[tear]] | [[whirl]] | [[whiz]] | [[zip]]
__Concepts__: [[ACTIONS - MOTION#move oneself quickly (150)\|move oneself quickly]]
__Antonyms__: decelerate, [[slow]]
## [[zip]] _[n]_
>[[enthusiasm]], [[energy]]
__Synonyms__: brio | [[drive]] | [[get]]-upand-[[go]] | [[go]] | [[gusto]] | [[life]] | liveliness | [[oomph]] | [[pep]] | [[pizzazz]] | [[punch]] | [[sparkle]] | [[spirit]] | [[verve]] | [[vigor]] | vim | [[vitality]] | [[zest]] | [[zing]]
__Concepts__: [[LIFE FORMS - GENERAL CHARACTERISTICS#personality (411)\|personality]], [[STATES - ABSTRACT#behavior (633)\|behavior]]
__Antonyms__: [[apathy]], enervation, [[idleness]], [[laziness]], [[lethargy]]
## [[zip]] _[v]_
>[[move]] | [[about]] | [[quickly]]
__Synonyms__: [[bustle]] | [[dash]] | [[flash]] | [[fly]] | [[hasten]] | [[hurry]] | [[run]] | [[rush]] | [[shoot]] | [[speed]] | [[tear]] | waltz | [[whisk]] | [[whiz]] | [[zoom]]
__Concepts__: [[ACTIONS - MOTION#move oneself quickly (150)\|move oneself quickly]]
__Antonyms__: decelerate, [[slow]]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}