#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<{\s*_N\s*\(([^\)]*)\)\s*}>?"
Local $sString = "<{_N( 'some_domain_id' , 'this can be an arbitary string',{'a':'b','c':'d'})|e('modifier')}>" & @CRLF & _
"<{_N( 'some_domain_id' , 'this can be an arbitary string') |e('modifier')}>" & @CRLF & _
"<{_N( 'some_domain_id' , 'this can be an arbitary string')| e('modifier')}>" & @CRLF & _
"<{_N( 'some_domain_id' , 'this can be an arbitary string') |e('modifier')}>" & @CRLF & _
"<{_N( 'some_domain_id' , 'this can be an arbitary string') | e('modifier')}>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")