import re
regex = re.compile(r"<{\s*_N\s*\(([^\)]*)\)\s*}>?")
test_str = ("<{_N( 'some_domain_id' , 'this can be an arbitary string',{'a':'b','c':'d'})|e('modifier')}>\n"
"<{_N( 'some_domain_id' , 'this can be an arbitary string') |e('modifier')}>\n"
"<{_N( 'some_domain_id' , 'this can be an arbitary string')| e('modifier')}>\n"
"<{_N( 'some_domain_id' , 'this can be an arbitary string') |e('modifier')}>\n"
"<{_N( 'some_domain_id' , 'this can be an arbitary string') | e('modifier')}>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")