$re = '/Instruction:\s*(.*)(?=Input:)/ms';
$str = 'Instruction: Create a new directory for your project.
Input: None';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);