$re = '/(?<=[\w\s])\d{8}/m';
$str = 'toll free number: 0008-00210000
sr01299100
sr 01299100
sr 01299100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);