re = /(?<=[\w\s])\d{8}/m
str = 'toll free number: 0008-00210000
sr01299100
sr 01299100
sr 01299100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end