package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.{1,50}$`)
var str = `afonaoadon
adonadoad aodnadonado ado
adad
adlnadln`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}