$re = '/^.{1,50}$/m';
$str = 'afonaoadon
adonadoad aodnadonado ado
adad
adlnadln';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);