$re = '/(?<![a-z])(?=[a-z]*e)(?![a-z]*ee)[a-z]+/i';
$str = 'need only single characteeer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);