re = /(?<![a-z])(?=[a-z]*e)(?![a-z]*ee)[a-z]+/i
str = 'need only single characteeer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end