$re = '/(\b(?!bogo|nai)\w*\b)\w+/m';
$str = 'sydney bogota berlin tokyo nairobi denver rio';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);