re = /(\b(?!bogo|nai)\w*\b)\w+/m
str = 'sydney bogota berlin tokyo nairobi denver rio'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end