$re = '/\(pp\.\s+\d+(?:-\d+)?\)|\b\d+(?:-\d+)?(?=(?:\s*,\s*\d+(?:-\d+)?)*\.)/m';
$str = '- Mitchell, J.A. (2017). Citation: Why is it so important. Mendeley Journal, 67(2), (pp. 81-95).
- Denhart, H. (2008). Deconstructing barriers: Perceptions of students labeled with learning disabilities in higher education. Journal of Learning Disabilities, 40,41, 483-497.
(pp. 81).
12-12
http://test.com/12-23
Usually the page numbers follow a commas and then there is a dot (like this: , 1-2. ) How can I change the code according to this? Same goes for when there is only one page listed , number. and the ` (pp. 12)` format.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);