const regex = new RegExp('^(?:Read\\s+more\\s*:)?\\s*(?:(?:[A-Z]\\S*|the|an?|[io]n|at|with(?:out)?|from|for|and|but|n?or|yet|[st]o|around|by|after|along|from|of)\\s+)*(?=[A-Z])', 'gm')
const str = `Read more: Indonesia to Get Moderna Vaccines Before the pandemic began, a lot of people were....`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);