$re = '/^(?:Read\s+more\s*:)?\s*(?:(?:[A-Z]\S*|the|an?|[io]n|at|with(?:out)?|from|for|and|but|n?or|yet|[st]o|around|by|after|along|from|of)\s+)*(?=[A-Z])/m';
$str = 'Read more: Indonesia to Get Moderna Vaccines Before the pandemic began, a lot of people were....';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;