import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[[:space:]]*dynamic[[:space:]]*=[[:space:]]*\\[[^]]*['\\\"]version['\\\"][^]]*\\]";
final String string = "dynamic = ['version']\n"
+ "dynamic = [ 'version' ]\n"
+ "dynamic = [\"version\"]\n"
+ "dynamic = [ \"version\" ]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}