$re = '/^[[:space:]]*dynamic[[:space:]]*=[[:space:]]*\[[^]]*[\'\"]version[\'\"][^]]*\]/m';
$str = 'dynamic = [\'version\']
dynamic = [ \'version\' ]
dynamic = ["version"]
dynamic = [ "version" ]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);