package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+([-+.]\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*)`)
var str = `Lorem Ipsum passages, and more recently with desktop publishing software
like Aldus PageMaker including versions of Lorem Ipsum.
info@amazon.com
abc@gmail.com
xy@
info@flipkart.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}