$re = '/(\w+([-+.]\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*)/m';
$str = 'Lorem Ipsum passages, and more recently with desktop publishing software
like Aldus PageMaker including versions of Lorem Ipsum.
info@amazon.com
abc@gmail.com
xy@
info@flipkart.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);