import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?>[^][]+|(?<c>)\\[|(?<-c>)])+]";
final String string = "[A] + -[B123]=0\n"
+ "[Test[0]]=0\n"
+ "[value] in the [text[42]] and [1[2[3]]]!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}