$re = '/([#.@]?[\w.:> -]){[\r\n]?([A-Za-z\- \r\n\t]+[:][\s]*[\w .\/()\-!#]+;[\r\n]*(?:[A-Za-z\- \r\n\t]+[:][\s]*[\w .\/()\-!]+;[\r\n]*(?2)*)*)}/';
$str = '.modal-content{
color: #fff;
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);