import Foundation
let pattern = ##"([#.@]?[\w.:> -]){[\r\n]?([A-Za-z\- \r\n\t]+[:][\s]*[\w .\/()\-!#]+;[\r\n]*(?:[A-Za-z\- \r\n\t]+[:][\s]*[\w .\/()\-!]+;[\r\n]*(?2)*)*)}"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
.modal-content{
color: #fff;
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}