using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.* (\[error]) .*(2: No such file or directory).*client: (?:::f{4,6}:)?(?P<host>\S+), .* request:.*(phpinfo|adminphp|admin|profiler|phpinfo|debug|apache|.env).*(HTTP\/1.1)";
string input = @"2024/12/25 15:35:07 [error] 45469#0: *3152 open() ""/var/www/html/.env"" failed (2: No such file or directory), client: 66.63.187.168, server: _, request: ""GET /.env HTTP/1.1"", host: ""23.43.19.64""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}