import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.* (\\[error]) .*(2: No such file or directory).*client: (?:::f{4,6}:)?(?P<host>\\S+), .* request:.*(phpinfo|adminphp|admin|profiler|phpinfo|debug|apache|.env).*(HTTP\\/1.1)";
final String string = "2024/12/25 15:35:07 [error] 45469#0: *3152 open() \"/var/www/html/.env\" failed (2: No such file or directory), client: 66.63.187.168, server: _, request: \"GET /.env HTTP/1.1\", host: \"23.43.19.64\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}