using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((([\w\s]+|\\,|\\'|\\;)+)(?:,?\s*))";
string input = @"'Dimensi on\, Na me1, Dimen\; si\'onName2, DimensionName3,DimensionName4, DimensionName5, DimensionName6";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}