re = /((([\w\s]+|\\,|\\'|\\;)+)(?:,?\s*))/i
str = '\'Dimensi on\\, Na me1, Dimen\\; si\\\'onName2, DimensionName3,DimensionName4, DimensionName5, DimensionName6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end