$re = '/^(\+[1-9]{2,3})?\s?([5-9](([0-9]|[\.\-]){4,12}))$/';
$str = '+91 814-992-0780';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);