re = /^(\+[1-9]{2,3})?\s?([5-9](([0-9]|[\.\-]){4,12}))$/
str = '+91 814-992-0780'
# Print the match result
str.match(re) do |match|
puts match.to_s
end