$re = '/^!*(?P<title>[A-Za-z0-9].+?)\s+(?P<isbn>[0-9]{10})\s+by\s+(?P<author>[A-Z0-9][^(]+)(?=\s\()/m';
$str = '!!Mixed Fortunes - An Economic History of China Russia and the West 0198703635 by Vladimir Popov (Jun 17, 2014 4_1).pdf
!Mixed Fortunes - An Economic History of China Russia and the West 0198703635 by Vladimir Popov (Jun 17, 2014 4_1).pdf
Mixed Fortunes - An Economic History of China Russia and the West 0198703635 by Vladimir Popov (Jun 17, 2014 4_1).pdf
!!Mixed Fortunes - An 893453454 Economic History of China Russia and the West by Vladimir Popov (Jun 17, 2014 4_1).pdf
!!Mixed Fortunes - An Economic History of China Russia and the West by 893453454 Vladimir Popov (Jun 17, 2014 4_1).pdf';
$subst = "\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;