# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^!*(?P<title>[A-Za-z0-9].+?)\s+(?P<isbn>[0-9]{10})\s+by\s+(?P<author>[A-Z0-9][^(]+)(?=\s\()"
test_str = ("!!Mixed Fortunes - An Economic History of China Russia and the West 0198703635 by Vladimir Popov (Jun 17, 2014 4_1).pdf\n"
"!Mixed Fortunes - An Economic History of China Russia and the West 0198703635 by Vladimir Popov (Jun 17, 2014 4_1).pdf\n"
"Mixed Fortunes - An Economic History of China Russia and the West 0198703635 by Vladimir Popov (Jun 17, 2014 4_1).pdf\n"
"!!Mixed Fortunes - An 893453454 Economic History of China Russia and the West by Vladimir Popov (Jun 17, 2014 4_1).pdf\n"
"!!Mixed Fortunes - An Economic History of China Russia and the West by 893453454 Vladimir Popov (Jun 17, 2014 4_1).pdf")
subst = "\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.