#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<filename>[a-zA-Z0-9\\-\\.\\/_]+.d)(?<line>\(\d+),(?<column>\d+)\): (?<level>.+(?=:))(?<message>.*)"
Local $sString = "source/parsers/x509.d(149,21): Error: function `std.typecons.Nullable!(Address[]).Nullable.length() const` is not callable using argument types `(ulong)`" & @CRLF & _
"source/parsers/x509.d(149,21): expected 0 argument(s), not 1" & @CRLF & _
"source/parsers/x509.d(151,60): Error: cannot implicitly convert expression `parseAddress(cast(const(char)[])split(cur_line[17], header.set_seperator)[i], null)` of type `std.socket.Address` to `Address[]`" & @CRLF & _
"source/parser.d(83,30): Error: template instance `parser.Parser.summarize!(X509)` error instantiating" & @CRLF & _
"Error /home/steveno/dlang/dmd-2.101.0/linux/bin64/dmd failed with exit code 1."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")