re = /(?<filename>[a-zA-Z0-9\\-\\.\\\/_]+.d)(?<line>\(\d+),(?<column>\d+)\): (?<level>.+(?=:))(?<message>.*)/
str = 'source/parsers/x509.d(149,21): Error: function `std.typecons.Nullable!(Address[]).Nullable.length() const` is not callable using argument types `(ulong)`
source/parsers/x509.d(149,21): expected 0 argument(s), not 1
source/parsers/x509.d(151,60): Error: cannot implicitly convert expression `parseAddress(cast(const(char)[])split(cur_line[17], header.set_seperator)[i], null)` of type `std.socket.Address` to `Address[]`
source/parser.d(83,30): Error: template instance `parser.Parser.summarize!(X509)` error instantiating
Error /home/steveno/dlang/dmd-2.101.0/linux/bin64/dmd failed with exit code 1.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end